WebGLのブラウザサポート

WebGLの対応ウェブブラウザは以下の通り。実際に利用する場合には加えてビデオカードが OpenGL 2.0 をサポートしている必要があります。セキュリティ上の問題から WebブラウザはGL_ARB_robustness (OpenGL 3.x) もしくは GL_EXT_robustness (OpenGL ES) の対応をチェックしています。その為にOpenGL 2.x 世代はウェブブラウザ側で強制的に利用する設定をしないと WebGL は利用できないようになっています。OpenGL 2.x 世代で強制的に利用する設定を行うことも可能ですが、この場合は無限ループなどでOSを停止させるDoS攻撃にさらされるリスクを負う事になります。
WebGLのブラウザサポート
Browser Platforms WebGL 1.0
IE 10 Windows (7, 8) No
IE 11 Windows (7, 8) Yes
Firefox 3 Linux, Mac OS X, Windows No
Firefox 4–current Linux, Mac OS X, Windows Yes
Chrome 8 Linux, Mac OS X, Windows (XP, Vista, 7, 8) disabled by default
Chrome 9–current Linux, Mac OS X, Windows (XP, Vista, 7, 8) Yes
Safari 5.1 Snow Leopard, Lion, Mountain Lion disabled by default
Safari 8 OSX Yosemite Yes
Opera 12–14 Linux, Mac OS X, Windows disabled by default
Opera 15–current Linux, Mac OS X, Windows Yes
iOS Safari 5–7 iOS 5–7 iAd only
iOS Safari 8 iOS 8 Yes
Android Browser Android 4–current Yes
Browser Platforms WebGL 1.0

関連文書