|BUF_TIMELOCK(9)||FreeBSD Kernel Developer's Manual||BUF_TIMELOCK(9)|
NAMEBUF_TIMELOCK — locks a buffer
SYNOPSIS#include < sys/param.h>
#include < sys/systm.h>
#include < sys/uio.h>
#include < sys/bio.h>
#include < sys/buf.h>
BUF_TIMELOCK( struct buf *bp, int locktype, char *wmesg, int catch, int timo);
DESCRIPTIONThe BUF_TIMELOCK() function locks the given buffer, and limits the amount of time it will sleep to timo and OR's catch into the sleep's priority. wmesg is the wmesg used in the sleep.
Its arguments are:
- The buffer to lock.
- Flags controlling the type of lock. See lockmgr(9) for details.
- The wmesg used in any sleeps while acquiring the lock.
- Priority OR'd into the sleep's priority.
- The timeout for any sleeps encountered during the lock.
RETURN VALUESA value of 0 is returned on success. See lockmgr(9) for details on non-zero return values.
AUTHORSThis manual page was written by <firstname.lastname@example.org>.
|July 9, 2001||FreeBSD|