|WPA_SUPPLICANT(8)||FreeBSD System Manager's Manual||WPA_SUPPLICANT(8)|
NAMEwpa_supplicant — WPA/802.11i Supplicant for wireless network devices
|wpa_supplicant||[ -BdhKLqstuvW][ -b br_ifname] -c config-file [ -C ctrl][ -D driver][ -f debug file][ -g global ctrl] -i ifname [ -o override driver][ -O override ctrl][ -P pid file][ -N -i ifname -c config-file [ -C ctrl][ -D -driver][ -p driver_param][ -b br_ifname] ...]|
DESCRIPTIONThe wpa_supplicant utility is an implementation of the WPA Supplicant component, i.e., the part that runs in the client stations. It implements WPA key negotiation with a WPA Authenticator and EAP authentication with an Authentication Server. In addition, wpa_supplicant controls the roaming and IEEE 802.11 authentication/association support of the wlan(4) module and can be used to configure static WEP keys based on identified networks.
The wpa_supplicant utility is designed to be a “daemon” program that runs in the background and acts as the backend component controlling the wireless connection. It supports separate frontend programs such as the text-based wpa_cli(8) program.
The following arguments must be specified on the command line:
- -i ifname
- Use the specified wireless interface.
- -c config-file
Use the settings in the specified configuration file when managing the wireless interface. See
wpa_supplicant.conf(5) for a description of the configuration file syntax and contents.
Changes to the configuration file can be reloaded by sending a SIGHUP to the wpa_supplicant process or with the wpa_cli(8) utility, using “
OPTIONSThe following options are available:
- Optional bridge interface name.
- Detach from the controlling terminal and run as a daemon process in the background.
- Enable debugging messages. If this option is supplied twice, more verbose messages are displayed.
- Driver name (can be multiple drivers: nl80211,wext).
- Log output to debug file instead of stdout.
- Global ctrl_interface.
- Show help text.
- Include key information in debugging output.
- Display the license for this program on the terminal and exit.
- Start describing a new interface.
- Overrides driver parameter for new interfaces.
- Override ctrl_interface parameter for new interfaces.
- Specify driver parameters.
- File in which to save the process PID.
- Decrease debugging verbosity (i.e., counteract the use of the -d flag).
- Send log messages through syslog(3) instead of to the terminal.
- Include timestamp in debug messages.
- Enable DBus control interface.
- Display version information on the terminal and exit.
- Wait for a control interface monitor before starting.
SEE ALSOan(4), ath(4), ipw(4), iwi(4), ral(4), rum(4), ural(4), wi(4), wlan(4), wpi(4), zyd(4), wpa_supplicant.conf(5), devd(8), ifconfig(8), wpa_cli(8)
HISTORYThe wpa_supplicant utility first appeared in FreeBSD 6.0.
AUTHORSThe wpa_supplicant utility was written by <email@example.com>. This manual page is derived from the README file included in the wpa_supplicant distribution.
|November 7, 2012||FreeBSD|