|VERSION.4TH(8)||FreeBSD System Manager's Manual||VERSION.4TH(8)|
NAMEversion.4th — FreeBSD version string boot module
DESCRIPTIONThe file that goes by the name of version.4th is a set of commands designed to draw the boot loader version at the bottom-right of the screen. The commands of version.4th by themselves are not enough for most uses. Please refer to the examples below for the most common situations, and to loader(8) for additional commands.
Before using any of the commands provided in version.4th, it must be included through the command:
This line is present in the default /boot/menu.rc file, so it is not needed (and should not be re-issued) in a normal setup.
The commands provided by it are:
- Prints the contents of the loader_version environment variable right-justified at the column loader_version_x and row loader_version_y.
The environment variables that effect its behavior are:
- Set automatically by loader(8), but you can override it by setting in loader.conf(5). This should be the version of boot loader used.
- Sets the desired ending column position of loader_version. Default is 80.
- Sets the desired ending row position of loader_version. Default is 24.
If set to “
NO” (case-insensitive) or “
0”, causes the version to be printed without color (default is ANSI Cyan).
HISTORYThe version.4th set of commands first appeared in FreeBSD 9.0.
AUTHORSThe version.4th set of commands was written by <dteske@FreeBSD.org>.
|August 6, 2013||FreeBSD|