|TZSETUP(8)||FreeBSD System Manager's Manual||TZSETUP(8)|
NAMEtzsetup — set local timezone
|tzsetup||[ -nrs][ -C chroot_directory][ zoneinfo_file | zoneinfo_name]|
DESCRIPTIONThe tzsetup utility reads a database of timezone information and presents a menu allowing the user to select a specific zone without knowing the details of the database layout. The selected zone is installed as the system default zone. The tzsetup utility also determines whether any adjustment is necessary for systems where the hardware clock does not keep UTC.
The following options are available:
- -C chroot_directory
- Open all files and directories relative to chroot_directory.
- Do not create or copy files.
- Reinstall the zoneinfo file installed last time. The name is obtained from /var/db/zoneinfo.
- Skip the initial question about adjusting the clock if not set to UTC.
It is possible to short-circuit the menu system by specifying the location of a zoneinfo_file or the name of the zoneinfo_name on the command line; this is intended mainly for pre-configured installation scripts or people who know which zoneinfo they want to install.
TIMEZONE DATABASEThe contents of the timezone database are indexed by /usr/share/zoneinfo/zone.tab. This file lists, for each timezone data file, the ISO 3166 territory code, approximate geographical coordinates (in ISO 6709 format), and location within the territory.
The maintainers of the database maintain the following policies:
- At least one zone for every country or inhabited geographical territory.
- One zone for every distinct, documented timezone history since the beginning of the UNIX epoch (January 1, 1970, GMT).
- Each zone is named for the most populous city therein. (Where possible, the database includes pre-1970 history for its city.)
The source code to the database ( /usr/src/share/zoneinfo/[a-z]*) contains many additional comments and documentation references for the historically minded.
- current time zone file
- see adjkerntz(8)
- mapping of ISO 3166 territory codes to names
- directory for zoneinfo files
- mapping of timezone file to country and location
- saved name of the timezone file installed last
EXAMPLESNormal usage, to select the right zoneinfo file via the dialog-based user interface:
Install the file /usr/share/zoneinfo/Australia/Sydney:
Install the zoneinfo file for Australia/Sydney, assumed to be located in /usr/share/zoneinfo:
After a reinstall of the zoneinfo files, you can reinstall the latest installed zoneinfo file (as specified in /var/db/zoneinfo):
DISCLAIMERThe representation of certain localities as being associated with certain countries and/or territories is for the purposes of identification only, and does not imply any endorsement or rejection on the part of the FreeBSD Project of the territorial claims of any entity.
BUGSPrograms which are already running when tzsetup creates or updates /etc/localtime will not reflect the updated timezone. When the system is first configured for a non-UTC hardware clock, it is necessary to run adjkerntz(8) (which normally happens as a part of system startup) in order to update the kernel's idea of the correct timezone offset.
|October 21, 2009||FreeBSD|