|TCPDROP(8)||FreeBSD System Manager's Manual||TCPDROP(8)|
NAMEtcpdrop — drop TCP connections
|tcpdrop||local-address local-port foreign-address foreign-port|
|tcpdrop||[ -l] -a|
DESCRIPTIONThe tcpdrop command may be used to drop TCP connections from the command line.
If -a is specified then tcpdrop will attempt to drop all active connections. The -l flag may be given to list the tcpdrop invocation to drop all active connections one at a time.
If -a is not specified then only the connection between the given local address local-address, port local-port, and the foreign address foreign-address, port foreign-port, will be dropped.
Addresses and ports may be specified by name or numeric value. Both IPv4 and IPv6 address formats are supported.
The addresses and ports may be separated by periods or colons instead of spaces.
EXIT STATUSThe tcpdrop utility exits 0 on success, and >0 if an error occurs.
EXAMPLESIf a connection to httpd(8) is causing congestion on a network link, one can drop the TCP session in charge:
# sockstat -c | grep httpd www httpd 16525 3 tcp4 \ 192.168.5.41:80 192.168.5.1:26747
The following command will drop the connection:
# tcpdrop 192.168.5.41 80 192.168.5.1 26747
The following command will drop all connections but those to or from port 22, the port used by sshd(8):
# tcpdrop -l -a | grep -vw 22 | sh
|January 30, 2013||FreeBSD|