|SERVICES_MKDB(8)||FreeBSD System Manager's Manual||SERVICES_MKDB(8)|
NAMEservices_mkdb — generate the services database
|services_mkdb||[ -b | -l][ -q][ -o database][ file]|
|services_mkdb||-u [ file]|
DESCRIPTIONThe services_mkdb utility creates a db(3) database for the specified file. If no file is specified, then /etc/services is used. The database is installed into /var/db/services.db. The file must be in the correct format (see services(5)).
The options are as follows:
- Use big-endian byte order for database metadata.
- Use little-endian byte order for database metadata.
- -o database
- Put the output databases in the named file.
- Do not warn about duplicate services.
- Print the services file to stdout, omitting duplicate entries and comments.
The databases are used by the C library services routines (see
The -b and -l flags are mutually exclusive. The default byte ordering is the current host order. getservent(3)).
- The current services database.
- A temporary file.
- The current services file.
EXIT STATUSThe services_mkdb utility exits 0 on success, and >0 if an error occurs.
BUGSBecause services_mkdb guarantees not to install a partial destination file it must build a temporary file in the same file system and if successful use rename(2) to install over the destination file.
If services_mkdb fails it will leave the previous version of the destination file intact.
|April 4, 2010||FreeBSD|