|DISKINFO(8)||FreeBSD System Manager's Manual||DISKINFO(8)|
NAMEdiskinfo — get information about disk device
|diskinfo||[ -ctv] disk ...|
DESCRIPTIONThe diskinfo utility prints out information about a disk device, and optionally runs a naive performance test on the device.
If given no arguments, the output will be a single line per specified device with the following fields: device name, sectorsize, media size in bytes, media size in sectors, stripe size, stripe offset, firmware cylinders, firmware heads, and firmware sectors. The last three fields are only present if the information is available.
If given the -v option, the fields will be printed one per line with a descriptive comment.
The -c option triggers a simple measurement of the I/O read command overhead.
The -t option triggers a simple and rather naive benchmark of the disks seek and transfer performance.
HISTORYThe diskinfo command appeared in FreeBSD 5.1.
BUGSThere are in order of increasing severity: lies, damn lies, statistics, and computer benchmarks.
|November 9, 2004||FreeBSD|