|BEASTIE.4TH(8)||FreeBSD System Manager's Manual||BEASTIE.4TH(8)|
NAMEbeastie.4th — FreeBSD ASCII art boot module
DESCRIPTIONThe file that goes by the name of beastie.4th is a set of commands designed to draw the ASCII art FreeBSD mascot — known simply as beastie — to the right of the boot loader menu. The commands of beastie.4th by themselves are not enough for most uses. Please refer to the examples below for the most common situations, and to loader(8) for additional commands.
Before using any of the commands provided in beastie.4th, it must be included through the command:
This line is present in the default /boot/loader.rc file, so it is not needed (and should not be re-issued) in a normal setup.
The commands provided by it are:
Draws the FreeBSD logo.
The logo that is drawn is configured by setting the loader_logo variable in loader.conf(5) to one of “
orb”, and “
orbbw” (the default).
The position of the logo can be configured by setting the loader_logo_x and loader_logo_y variables in loader.conf(5). The default values are 46 (x) and 4 (y).
Clears the screen of beastie.
Initializes the interactive boot loader menu.
The loader_delay variable can be configured in loader.conf(5) to the number of seconds you would like to delay loading the boot menu. During the delay the user can press Ctrl-C to fall back to autoboot or ENTER to proceed. The default behavior is to not delay.
The environment variables that effect its behavior are:
Selects the desired logo in the beastie boot menu. Possible values are: “
orbbw” (default), and “
- Sets the desired column position of the logo. Default is 46.
- Sets the desired row position of the logo. Default is 4.
- If set to “YES”, the beastie boot menu will be skipped. The beastie boot menu is always skipped if booting UEFI or running non-x86 hardware.
- If set to a number higher than zero, introduces a delay before starting the beastie boot menu. During the delay the user can press either Ctrl-C to skip the menu or ENTER to proceed to the menu. The default is to not delay when loading the menu.
EXAMPLESStandard i386 /boot/loader.rc:
include /boot/beastie.4th beastie-start
Set a different logo in loader.conf(5):
HISTORYThe beastie.4th set of commands first appeared in FreeBSD 5.1.
AUTHORSThe beastie.4th set of commands was written by <scottl@FreeBSD.org>, <firstname.lastname@example.org> and <dteske@FreeBSD.org>.
|April 27, 2014||FreeBSD|