|LINSYSFS(5)||FreeBSD File Formats Manual||LINSYSFS(5)|
NAMElinsysfs — Linux system file system
linsys /compat/linux/sys linsysfs rw 0 0
DESCRIPTIONThe Linux system file system, or linsysfs, emulates a subset of the Linux sys file system and is required for the complete operation of some Linux binaries.
The linsysfs provides a two-level view of devices. At the highest level, PCI devices themselves are named, according to their bus, slot and function in the system hierarchy. PCI storage devices are listed in the scsi_host class with a device symlink to the PCI directories of the devices.
Each device node is a directory containing some files and directories:
- A place holder for storage host information.
- A directory for the pci_id that contains either the device information or another directory structure for a PCI bridge.
Each host node of scsi_host is a directory containing some files and directories:
- The Linux registered driver name for these devices.
- A symlink to the PCI device directory.
- The normal mount point for linsysfs.
- The storage host node.
- The PCI device hierarchy node.
EXAMPLESThe most common usage follows:
mount -t linsysfs linsys /compat/linux/sys
where /compat/linux/sys is a mount point.
HISTORYThe linsysfs driver first appeared in FreeBSD 6.2.
AUTHORSThe linsysfs driver was derived from linprocfs by . This manual page was edited by , based on the linprocfs(5) manual page by .
|February 5, 2007||FreeBSD|