|VIRTIO(4)||FreeBSD Kernel Interfaces Manual||VIRTIO(4)|
NAMEvirtio — VirtIO Device Support
SYNOPSISTo compile VirtIO device support into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load VirtIO support as modules at boot time, place the following lines in loader.conf(5):
DESCRIPTIONVirtIO is a specification for para-virtualized I/O in a virtual machine (VM). Traditionally, the hypervisor emulated real devices such as an Ethernet interface or disk controller to provide the VM with I/O. This emulation is often inefficient.
VirtIO defines an interface for efficient I/O between the hypervisor and VM. The virtio module provides a shared memory transport called a virtqueue. The virtio_pci device driver represents an emulated PCI device that the hypervisor makes available to the VM. This device provides the probing, configuration, and interrupt notifications needed to interact with the hypervisor. FreeBSD supports the following VirtIO devices:
- An emulated Ethernet device is provided by the vtnet(4) device driver.
- An emulated disk controller is provided by the virtio_blk(4) device driver.
- An emulated SCSI HBA is provided by the virtio_scsi(4) device driver.
- A pseudo-device to allow the VM to release memory back to the hypervisor is provided by the virtio_balloon(4) device driver.
HISTORYSupport for VirtIO first appeared in FreeBSD 9.0.
AUTHORSFreeBSD support for VirtIO was first added by <bryanv@FreeBSD.org>.
|January 22, 2012||FreeBSD|