|UMCS(4)||FreeBSD Kernel Interfaces Manual||UMCS(4)|
NAMEumcs — USB support for serial adapters based on the MCS7820 and MCS7840 chips
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe umcs driver provides support for various multiport serial adapters based on the MosCom MCS7820 and MCS7840 chips. They are 2- or 4-port adapters with full-featured 16550-compatible UARTs and very flexible baud generators. Also, these chips support RS422/RS485 and IrDA operations.
Different ports on device are presented as sub-units, like /dev/ttyU0.1 and /dev/ttyU0.2.
HARDWAREThe umcs driver was tested on the following adapters:
- ST Lab U-360 two-port serial USB adapter
- ST Lab U-400 four-port serial USB adapter
HISTORYThe umcs driver appeared in ports since December of 2010.
AUTHORSThe umcs driver was written by <lev@FreeBSD.org>.
BUGSThis driver doesn't support access to any fine tunes of chip, like RS522/RS485 mode, non-standard baudrates, etc.
|February 25, 2012||FreeBSD|