|UBTBCMFW(4)||FreeBSD Kernel Interfaces Manual||UBTBCMFW(4)|
NAMEubtbcmfw — Firmware driver for Broadcom BCM2033 chip based Bluetooth USB devices
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe ubtbcmfw is a firmware driver for Broadcom BCM2033 chip based Bluetooth USB devices. It provides minimal access to the parts of the device required to download firmware.
The ubtbcmfw driver creates three fixed endpoint device nodes.
The control transfers can only happen on the control endpoint which is always endpoint 0. Control requests are issued by ioctl(2) calls.
Only incoming transfers are supported on an interrupt endpoint. To perform I/O on an interrupt endpoint, read(2) should be used. All I/O operations on an interrupt endpoint are unbuffered. Interrupt endpoint is always endpoint 1.
Only outgoing bulk transfers are supported on a bulk endpoint. To perform I/O on a bulk endpoint, write(2) should be used. All I/O operations on a bulk endpoint are unbuffered. Outgoing bulk endpoint is always endpoint 2.
The control endpoint (endpoint 0) handles the following ioctl(2) calls:
- USB_GET_DEVICE_DESC ( usb_device_descriptor_t)
- Return the device descriptor.
- /dev/ubtbcmfw N . EE
- Endpoint EE of device N.
HISTORYThe ubtbcmfw driver was implemented in FreeBSD 5.0.
BUGSMost likely. Please report if found.
|November 22, 2006||FreeBSD|