|PST(4)||FreeBSD Kernel Interfaces Manual||PST(4)|
NAMEpst — device driver for Promise Supertrak SX6000
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThis driver is for the Promise Supertrak SX6000 ATA hardware RAID controller. It supports (in hardware) RAID levels 0, 1, 0+1, 3, 5 and JBOD on up to 6 ATA disk drives, including automatic rebuild and hotswap, and supports signalling disk status on LEDs on Promise Superswap disk enclosures. The Supertrak line of controllers does not support non-disk devices.
HARDWAREThe pst driver supports the Promise Supertrak SX6000 ATA hardware RAID controller.
NOTESThe pst driver does not support manipulating the RAID from the OS, RAIDs need to be set up from the onboard BIOS. However, hot swap, hot spare, and automatic rebuilds are supported without a reboot.
HISTORYThe pst driver first appeared in FreeBSD 4.7.
AUTHORSThe pst driver and man page was written by <sos@FreeBSD.org>.
|December 14, 2004||FreeBSD|