|NG_BT3C(4)||FreeBSD Kernel Interfaces Manual||NG_BT3C(4)|
NAMEng_bt3c — Netgraph node type that is also a 3Com Bluetooth PC card driver
DESCRIPTIONThe btccc node type is both a persistent Netgraph node type and a driver for the 3Com Bluetooth PC card (3CRWB6096-HP). It implements a Bluetooth HCI UART transport layer as per chapter H4 of the Bluetooth Specification Book v1.1. A new node is created when the card is plugged.
In order to use the card one MUST download the firmware first. Due to copyright issues the firmware cannot be provided with this driver. The firmware can be obtained from the Windows driver package that can be downloaded from the 3Com web site at no charge. The firmware name is BT3CPCC.BIN. To load the firmware into the card, use bt3cfw(8). I am using the original firmware that came with the card on CD-ROM.
MD5 (BT3CPCC.BIN) = 36170fda56ea9fdbf1702c966f8a97f1
The node has a single hook called hook. Incoming bytes received on the device are re-assembled into HCI frames (according to the length). Full HCI frames are sent out on the hook. HCI frames received on hook are transmitted out. No modification to the data is performed in either direction.
HARDWAREThe ng_bt3c driver provides support for the 3Com/HP 3CRWB6096-A PCCARD bluetooth adapter.
HOOKSThis node type supports the following hooks:
- single HCI frame contained in single mbuf structure.
CONTROL MESSAGESThis node type supports the generic control messages, plus the following:
- NGM_BT3C_NODE_GET_STATE ( get_state)
- Returns the current receiving state for the node.
- NGM_BT3C_NODE_SET_DEBUG ( set_debug)
- This command takes an integer argument and sets the current debug level for the node.
- NGM_BT3C_NODE_GET_DEBUG ( get_debug)
- Returns an integer containing the current debug level for the node.
- NGM_BT3C_NODE_GET_QLEN ( get_qlen)
- This command takes a parameter that specifies queue number and returns the current length of the queue for the node.
- NGM_BT3C_NODE_SET_QLEN ( set_qlen)
- This command takes two parameters that specify the queue number and the maximum length of the queue and sets the maximum length of the queue for the node.
- NGM_BT3C_NODE_GET_STAT ( get_stat)
- Returns various statistic information for the node, such as: number of bytes (frames) sent, number of bytes (frames) received and number of input (output) errors.
- NGM_BT3C_NODE_RESET_STAT ( reset_stat)
- Reset all statistic counters to zero.
- Download card firmware.
SHUTDOWNThis node shuts down when the corresponding card is un-plugged.
HISTORYThe btccc node type was implemented in FreeBSD 5.0.
BUGSThe driver is based on information obtained from <firstname.lastname@example.org> and disassembled the W2K driver.
|December 17, 2004||FreeBSD|