|MALO(4)||FreeBSD Kernel Interfaces Manual||MALO(4)|
NAMEmalo — Marvell Libertas IEEE 802.11b/g wireless network driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following lines in loader.conf(5):
DESCRIPTIONThe malo driver provides support for Marvell Libertas 88W8335 based PCI and Cardbus network adapters. malo supports station and monitor mode operation. Only one virtual interface may be configured at any time. For more information on configuring this device, see ifconfig(8).
This driver requires the malofw firmware kernel module be installed before it will work. The firmware files are not publicly available. A port of the firmware can be found at:
The firmware kernel module can be installed by extracting the archive and running ‘
make install clean’ in the malo-firmware-1.4 directory.
HARDWAREThe following cards are among those supported by the malo driver:
EXAMPLESJoin an existing BSS network (i.e., connect to an access point):
ifconfig wlan create wlandev malo0 inet 192.168.0.20 \ netmask 0xffffff00
Join a specific BSS network with network name “
ifconfig wlan create wlandev malo0 ssid my_net up
Join a specific BSS network with 64-bit WEP encryption:
ifconfig wlan create wlandev malo0 ssid my_net \ wepmode on wepkey 0x1234567890 weptxkey 1 up
SEE ALSOcardbus(4), pci(4), wlan(4), wlan_ccmp(4), wlan_tkip(4), wlan_wep(4), ifconfig(8), wpa_supplicant(8)
HISTORYThe malo device driver first appeared in FreeBSD 7.1.
|October 21, 2009||FreeBSD|