|VM_MAP_SIMPLIFY_ENTRY(9)||FreeBSD Kernel Developer's Manual||VM_MAP_SIMPLIFY_ENTRY(9)|
NAMEvm_map_simplify_entry — simplify a vm_map_entry
SYNOPSIS#include < sys/param.h>
#include < vm/vm.h>
#include < vm/vm_map.h>
vm_map_simplify_entry( vm_map_t map, vm_map_entry_t entry);
DESCRIPTIONThe vm_map_simplify_entry() function simplifies the given entry by merging with either neighbour. The map must be locked upon entry.
This function also has the ability to merge with both neighbours.
This function guarantees that the passed entry remains valid, although possibly extended.
AUTHORSThis manual page was written by <email@example.com>.
|July 19, 2003||FreeBSD|