|VGONE(9)||FreeBSD Kernel Developer's Manual||VGONE(9)|
NAMEvgone — prepare a vnode for reuse
DESCRIPTIONThe vgone() function prepares the vnode to be destroyed. The preparation includes the cleaning of all file system specific data and the removal from its mount point vnode list.
If the vnode has a v_usecount of zero, and its VI_DOOMED flag is not set, it is moved to the head of the free list as in most cases the vnode is about to be reused, or its file system is being unmounted.
The vgone() function takes an exclusively locked vnode, and returns with the vnode exclusively locked.
AUTHORSThis manual page was written by <email@example.com>.
|November 12, 2010||FreeBSD|