|VFS_BUSY(9)||FreeBSD Kernel Developer's Manual||VFS_BUSY(9)|
NAMEvfs_busy — marks a mount point as busy
SYNOPSIS#include < sys/param.h>
#include < sys/mount.h>
vfs_busy( struct mount *mp, int flags);
DESCRIPTIONThe vfs_busy() function marks a mount point as busy by incrementing the reference count of a mount point. It also delays unmounting by sleeping on mp if the MNTK_UNMOUNT flag is set in mp->mnt_kern_flag and the MBF_NOWAIT flag is not set.
Its arguments are:
- The mount point to busy.
Flags controlling how
vfs_busy() should act.
- do not sleep if MNTK_UNMOUNT is set.
- drop the mountlist_mtx in the critical path.
RETURN VALUESA 0 value is returned on success. If the mount point is being unmounted and MBF_NOWAIT flag is specified ENOENT will be returned.
- [ ENOENT]
- The mount point is being unmounted ( MNTK_UNMOUNT is set).
AUTHORSThis manual page was written by <firstname.lastname@example.org>.
|February 11, 2013||FreeBSD|