|PMAP_RESIDENT_COUNT(9)||FreeBSD Kernel Developer's Manual||PMAP_RESIDENT_COUNT(9)|
NAMEpmap_resident_count, pmap_wired_count — return page resident and wiring statistics
SYNOPSIS#include < sys/param.h>
#include < vm/vm.h>
#include < vm/pmap.h>
pmap_resident_count( pmap_t pmap);
pmap_wired_count( pmap_t pmap);
DESCRIPTIONThe pmap_resident_count() and pmap_wired_count() macros allow pmap consumers to retrieve statistics from the pm_stats member of the machine-dependent structure struct pmap.
IMPLEMENTATION NOTESBoth functions are defined as in-line macros. The members which they access have type long.
RETURN VALUESThe pmap_resident_count() returns the number of pages in the physical map pmap which are currently resident in main memory.
The pmap_wired_count() returns the number of pages in the physical map pmap which are currently wired into in main memory.
AUTHORSThis manual page was written by <email@example.com>.
|July 21, 2003||FreeBSD|