|PMAP_MINCORE(9)||FreeBSD Kernel Developer's Manual||PMAP_MINCORE(9)|
NAMEpmap_mincore — determine if a virtual address is resident in physical memory
SYNOPSIS#include < sys/param.h>
#include < vm/vm.h>
#include < vm/pmap.h>
pmap_mincore( pmap_t pmap, vm_offset_t addr);
DESCRIPTIONThe pmap_mincore() function determines if the page at the virtual address addr in the physical map pmap is resident in physical memory. It is the machine-dependent interface used by the mincore(2) system call.
RETURN VALUESIf the page is resident in physical memory, a mask of flags is returned, whose meaning is documented in mincore(2); otherwise, 0 is returned.
The pmap must exist and addr must be mapped into the pmap. If any error occurs, the machine-dependent implementation should return 0.
AUTHORSThis manual page was written by <firstname.lastname@example.org>.
|July 21, 2003||FreeBSD|