|BUS_ACTIVATE_RESOURCE(9)||FreeBSD Kernel Developer's Manual||BUS_ACTIVATE_RESOURCE(9)|
NAMEbus_activate_resource, bus_deactivate_resource — activate or deactivate a resource
SYNOPSIS#include < sys/param.h>
#include < sys/bus.h>
bus_activate_resource( device_t dev, int type, int rid, struct resource *r);
bus_deactivate_resource( device_t dev, int type, int rid, struct resource *r);
DESCRIPTIONThese functions activate or deactivate a previously allocated resource. In general, resources must be activated before they can be accessed by the driver so that the bus driver can map the resource into the devices space.
The arguments are as follows:
- The device that requests ownership of the resource. Before allocation, the resource is owned by the parent bus.
The type of resource you want to allocate. It is one of:
- for IRQs
- for ISA DMA lines
- for I/O ports
- for I/O memory
- A pointer to a bus specific handle that identifies the resource being allocated.
- A pointer to the struct resource returned by bus_alloc_resource(9).
RETURN VALUESZero is returned on success, otherwise an error is returned.
AUTHORSThis manual page was written by <imp@FreeBSD.org>.
|March 28, 2003||FreeBSD|