|BOOT(9)||FreeBSD Kernel Developer's Manual||BOOT(9)|
NAMEboot — halt or reboot the system
SYNOPSIS#include < sys/types.h>
#include < sys/systm.h>
#include < sys/reboot.h>
boot( int howto);
DESCRIPTIONThe boot() function handles final system shutdown, and either halts or reboots the system. The exact action to be taken is determined by the flags passed in howto and by whether or not the system has finished autoconfiguration.
If the system has finished autoconfiguration, boot() does the following:
- If this is the first invocation of boot() and the RB_NOSYNC flag is not set in howto, syncs and unmounts the system disks by calling vfs_unmountall(9).
- Disables interrupts.
- If rebooting after a crash (i.e., if RB_DUMP is set in howto, but RB_HALT is not), saves a system crash dump.
- Runs any shutdown hooks previously registered.
- Prints a message indicating that the system is about to be halted or rebooted.
- If RB_HALT is set in howto, halts the system. Otherwise, reboots the system.
If the system has not finished autoconfiguration, boot() runs any shutdown hooks previously registered, prints a message, and halts the system.
|February 14, 1997||FreeBSD|