|VOP_READLINK(9)||FreeBSD Kernel Developer's Manual||VOP_READLINK(9)|
NAMEVOP_READLINK — read the target of a symbolic link
SYNOPSIS#include < sys/param.h>
#include < sys/vnode.h>
#include < sys/uio.h>
VOP_READLINK( struct vnode *vp, struct uio *uio, struct ucred *cred);
DESCRIPTIONThis reads the target pathname of a symbolic link
- The vnode of the symlink.
- The location of the data to be read or written.
- The credentials of the caller.
LOCKSThe vnode should be locked on entry and will still be locked on exit.
RETURN VALUESZero is returned on success, otherwise an error code is returned.
- [ EIO]
- A read error occurred while reading the contents of the symlink.
AUTHORSThis manual page was written by .
|July 24, 1996||FreeBSD|