|VOP_LISTEXTATTR(9)||FreeBSD Kernel Developer's Manual||VOP_LISTEXTATTR(9)|
NAMEVOP_LISTEXTATTR — retrieve a list of named extended attribute from a vnode
SYNOPSIS#include < sys/param.h>
#include < sys/vnode.h>
#include < sys/extattr.h>
VOP_LISTEXTATTR( struct vnode *vp, int attrnamespace, struct uio *uio, size_t *size, struct ucred *cred, struct thread *td);
DESCRIPTIONThis vnode call may be used to retrieve a list of named extended attributes from a specified namespace on a file or directory.
Its arguments are:
- The vnode of the file or directory.
- Integer constant indicating which extended attribute namespace the attribute name is present in.
- The location of the data to be read. The resulting data will be a list of attribute names. Each list entry consists of a single byte containing the length of the attribute name, followed by the attribute name. The attribute name is not terminated by ASCII NUL.
- If not NULL, on return it will contain the number of bytes required to read the list. In most cases uio will be NULL when size is not, and vice versa.
- The user credentials to use in authorizing the request.
- The thread requesting the extended attribute.
The cred pointer may be NULL to indicate that access control checks are not to be performed, if possible. This cred setting might be used to allow the kernel to authorize extended attribute retrieval that the active process might not be permitted to do.
Extended attribute semantics may vary by file system implementing the call. More information on extended attributes may be found in extattr(9).
LOCKSThe vnode will be locked on entry and should remain locked on return.
RETURN VALUESOn success, zero will be returned, and the uio structure will be updated to reflect the list read. Otherwise, an appropriate error code is returned.
- [ EACCES]
- The caller does not have the appropriate privilege.
- [ ENXIO]
- The request was not valid in this file system for the specified vnode and attribute name.
- [ ENOMEM]
- Sufficient memory is not available to fulfill the request.
- [ EFAULT]
- The uio structure refers to an invalid userspace address.
- [ EINVAL]
- The namespace or uio argument is invalid.
- [ EOPNOTSUPP]
- The file system does not support VOP_LISTEXTATTR().
|August 19, 2005||FreeBSD|