|VFS_SYNC(9)||FreeBSD Kernel Developer's Manual||VFS_SYNC(9)|
NAMEVFS_SYNC — flush unwritten data
SYNOPSIS#include < sys/param.h>
#include < sys/mount.h>
#include < sys/vnode.h>
VFS_SYNC( struct mount *mp, int waitfor);
DESCRIPTIONThe VFS_SYNC() macro writes out all unwritten data in the file system mounted as mp.
The arguments it expects are:
- The file system.
Whether the function should wait for I/O to complete. Possible values are:
- synchronously wait for I/O to complete
- start all I/O, but do not wait for it
- push data not written by file system syncer
The VFS_SYNC() macro calls the vfs_sync method of the file system, which normally calls VOP_FSYNC(9) for all the vnodes in the file system.
AUTHORSThis manual page was written by .
|May 23, 2009||FreeBSD|