|BUS_CHILD_DETACHED(9)||FreeBSD Kernel Developer's Manual||BUS_CHILD_DETACHED(9)|
NAMEBUS_CHILD_DETACHED — notify a bus device that a child was detached
SYNOPSIS#include < sys/param.h>
#include < sys/bus.h>
BUS_CHILD_DETACHED( device_t dev, device_t child);
DESCRIPTIONThe BUS_CHILD_DETACHED() method is invoked by the new-bus framework after a device is detached. A bus driver can provide an implementation of this method to reclaim any resources allocated on behalf of the child or to cleanup state not properly released by a DEVICE_DETACH(9) method.
|August 21, 2012||FreeBSD|