|BUF_LOCKFREE(9)||FreeBSD Kernel Developer's Manual||BUF_LOCKFREE(9)|
NAMEBUF_LOCKFREE — destroys a buffer's lock
SYNOPSIS#include < sys/param.h>
#include < sys/systm.h>
#include < sys/uio.h>
#include < sys/bio.h>
#include < sys/buf.h>
BUF_LOCKFREE( struct buf *bp);
DESCRIPTIONThe BUF_LOCKFREE() macro destroys the buffer lock. The lock must not be held when this macro is called or a panic will result.
Its argument is:
- The buffer whose lock is to be destroyed.
AUTHORSThis manual page was written by <firstname.lastname@example.org>.
|July 9, 2001||FreeBSD|