EN JA
BUF_LOCK(9)
BUF_LOCK(9) FreeBSD Kernel Developer's Manual BUF_LOCK(9)

NAME

BUF_LOCKlocks a buffer

SYNOPSIS

#include < sys/param.h>
#include < sys/systm.h>
#include < sys/uio.h>
#include < sys/bio.h>
#include < sys/buf.h>

int
BUF_LOCK( struct buf *bp, int locktype);

DESCRIPTION

The BUF_LOCK() function locks the given buffer. If the lock is already held this call will block until it can acquire the lock unless LK_NOWAIT is set.

Its arguments are:

bp
The buffer to lock.
locktype
Flags controlling the type of lock. See lockmgr(9) for details.

RETURN VALUES

A value of 0 is returned upon success. See lockmgr(9) for information on non-zero return values.

AUTHORS

This manual page was written by Chad David <davidc@acns.ab.ca>.
July 9, 2001 FreeBSD