|YPINIT(8)||FreeBSD System Manager's Manual||YPINIT(8)|
NAMEypinit — build and install NIS databases
|ypinit||-m [ domainname]|
|ypinit||-s master_server [ domainname]|
|ypinit||-u [ domainname]|
DESCRIPTIONThe ypinit utility is a script which sets up databases on a Network Information Service (NIS) master or slave server.
On a master server, ypinit creates the /var/yp/$DOMAINNAME directory, the /var/yp/ypservers file, and calls /var/yp/Makefile to create and populate an initial set of NIS maps. The maps are created from local source files using the yp_mkdb(8) utility. The utility will prompt the user for a list of servers that support the specified domain; this list is used to populate the ypservers map.
On a slave server, ypinit creates the /var/yp/$DOMAINNAME, populates it with copies of the NIS maps from the master. The maps are obtained from the master using the ypxfr(8) utility. The ypinit utility obtains the list of maps to transfer in one of two ways: if the system is configured as an NIS client and is bound to the master server, ypinit is able to use the ypwhich(1) utility to obtain a list of maps exported by the master server. If the system is not configured as a client of the NIS master, ypinit uses a hardcoded list of maps, some of which may or may not actually exist on the master. The system administrator can edit the ypinit script and modify the map list if necessary. Otherwise, individual maps can be transferred manually from the master using ypxfr(8).
OPTIONSThe ypinit utility supports the following options:
- -m [ domainname]
- Set up a master server. By default, ypinit sets up a server for the system default domain. The user can override this default by specifying domainname explicitly. Maps are constructed from scratch using local files as templates using the yp_mkdb(8) utility.
- -s master_server [ domainname]
- Set up a slave server using master_name as the master. Maps are copied from master_server to the slave using ypxfr(8). By default, ypinit sets up a server for the system default domain. The user can override this default by specifying domainname explicitly.
- -u [ domainname]
- Update the ypservers map on the master server. When a new slave server is added to a domain, its hostname must be added to the ypservers map so that yppush(8) can propagate updates on the master to all of the slaves.
- Bootparams source file
- Ethers data source file
- Group source file
- Hostname/IP address source file
- RPC netid source file
- Networks source file
- Protocols source file
- RPC public key/secret key source file
- Services data source file
- Shells source file
- Passwd database source file
- Netgroup data source file
- Ypservers source file (generated by ypinit)
HISTORYThis version of ypinit is based on the ypinit script in OpenBSD. It first appeared in FreeBSD 3.0.
AUTHORSThe original script was written by <firstname.lastname@example.org>. It was modified for FreeBSD by <email@example.com>.
|November 10, 1997||FreeBSD|