|WATCHDOGD(8)||FreeBSD System Manager's Manual||WATCHDOGD(8)|
NAMEwatchdogd — watchdog daemon
|watchdogd||[ -dnSw][ --debug][ --softtimeout][ --softtimeout-action action][ --pretimeout timeout][ --pretimeout-action action][ -e cmd][ -I file][ -s sleep][ -t timeout][ -T script_timeout]|
DESCRIPTIONThe watchdogd utility interfaces with the kernel's watchdog facility to ensure that the system is in a working state. If watchdogd is unable to interface with the kernel over a specific timeout, the kernel will take actions to assist in debugging or restarting the computer.
If -e cmd is specified, watchdogd will attempt to execute this command with system(3), and only if the command returns with a zero exit code will the watchdog be reset. If -e cmd is not specified, the daemon will perform a trivial file system check instead.
The -n argument 'dry-run' will cause watchdog not to arm the system watchdog and instead only run the watchdog function and report on failures. This is useful for developing new watchdogd scripts as the system will not reboot if there are problems with the script.
The -s sleep argument can be used to control the sleep period between each execution of the check and defaults to one second.
The -t timeout specifies the desired timeout period in seconds. The default timeout is 16 seconds.
One possible circumstance which will cause a watchdog timeout is an interrupt storm. If this occurs, watchdogd will no longer execute and thus the kernel's watchdog routines will take action after a configurable timeout.
The -T script_timeout specifies the threshold (in seconds) at which the watchdogd will complain that its script has run for too long. If unset script_timeout defaults to the value specified by the -s sleep option.
Upon receiving the SIGTERM or SIGINT signals, watchdogd will first instruct the kernel to no longer perform watchdog checks and then will terminate.
The watchdogd utility recognizes the following runtime options:
- -I file
- Write the process ID of the watchdogd utility in the specified file.
- -d --debug
- Do not fork. When this option is specified, watchdogd will not fork into the background at startup.
- Do not send a message to the system logger when the watchdog command takes longer than expected to execute. The default behaviour is to log a warning via the system logger with the LOG_DAEMON facility, and to output a warning to standard error.
- Complain when the watchdog script takes too long. This flag will cause watchdogd to complain when the amount of time to execute the watchdog script exceeds the threshold of 'sleep' option.
- --pretimeout timeout
- Set a "pretimeout" watchdog. At "timeout" seconds before the watchdog will fire attempt an action. The action is set by the --pretimeout-action flag. The default is just to log a message (WD_SOFT_LOG) via log(9).
- --pretimeout-action action
- Set the timeout action for the pretimeout. See the section Timeout Actions.
- Instead of arming the various hardware watchdogs, only use a basic software watchdog. The default action is just to log(9) a message (WD_SOFT_LOG).
- --softtimeout-action action
- Set the timeout action for the softtimeout. See the section Timeout Actions.
Timeout ActionsThe following timeout actions are available via the --pretimeout-action and --softtimeout-action flags:
- Call panic(9) when the timeout is reached.
- Enter the kernel debugger via kdb_enter(9) when the timeout is reached.
- Log a message using log(9) when the timeout is reached.
- call the kernel printf(9) to display a message to the console and dmesg(8) buffer.
Debugging watchdogd and/or your watchdog script.This is a useful recipe for debugging watchdogd and your watchdog script.
(Note that ^C works oddly because watchdogd calls system(3) so the first ^C will terminate the "sleep" command.)
Explanation of options used:
- Set Debug on (--debug)
- Set the watchdog to trip at 30 seconds. (-t 30)
- Use of a softtimeout:
- Use of a pre-timeout:
- Use of a script:
- Run "sleep 60" as a shell command that acts as the watchdog (-e 'sleep 60')
- Warn us when the script takes longer than 1 second to run (-w)
watchdogd --debug -t 30 \ --softtimeout --softtimeout-action log,printf \ --pretimeout 15 --pretimeout-action log,printf \ -e 'sleep 60' -w
Production use of example
- Set hard timeout to 120 seconds (-t 120)
- Set a panic to happen at 60 seconds (to trigger a crash(8) for dump analysis):
- Use of pre-timeout (--pretimeout 60)
- Specify pre-timeout action (--pretimeout-action log,printf,panic )
- Use of a script:
- Run your script (-e '/path/to/your/script 60')
- Log if your script takes a longer than 15 seconds to run time. (-w -T 15)
watchdogd -t 120 \ --pretimeout 60 --pretimeout-action log,printf,panic \ -e '/path/to/your/script 60' -w -T 15
HISTORYThe watchdogd utility appeared in FreeBSD 5.1.
AUTHORSThe watchdogd utility and manual page were written by <smkelly@FreeBSD.org> and <phk@FreeBSD.org>.
Some contributions made by<jeff@FreeBSD.org>.
The pretimeout and softtimeout action system was added by<firstname.lastname@example.org>.
|July 27, 2013||FreeBSD|