|SYNC(8)||FreeBSD System Manager's Manual||SYNC(8)|
NAMEsync — force completion of pending disk writes (flush cache)
DESCRIPTIONThe sync utility can be called to ensure that all disk writes have been completed before the processor is halted in a way not suitably done by reboot(8) or halt(8). Generally, it is preferable to use reboot(8) or halt(8) to shut down the system, as they may perform additional actions such as resynchronizing the hardware clock and flushing internal caches before performing a final sync.
The sync utility utilizes the sync(2) function call.
HISTORYA sync utility appeared in Version 4 AT&T UNIX.
|May 31, 1993||FreeBSD|