|NFSIOD(8)||FreeBSD System Manager's Manual||NFSIOD(8)|
NAMEnfsiod — local NFS asynchronous I/O server
|nfsiod||[ -n num_servers]|
DESCRIPTIONThe nfsiod utility controls the maximum number of nfsiod kernel processes which run on an NFS client machine to service asynchronous I/O requests to its server. Having nfsiod kernel processes improves performance but is not required for correct operation.
The option is as follows:
- Specify how many processes are permitted to be started.
Without an option, nfsiod displays the current settings. A client should allow enough number of processes to handle its maximum level of concurrency, typically four to six.
If nfsiod detects that the running kernel does not include NFS support, it will attempt to load a kernel module containing NFS code, using kldload(2). If this fails, or no NFS module was available, nfsiod exits with an error.
EXIT STATUSThe nfsiod utility exits 0 on success, and >0 if an error occurs.
HISTORYThe nfsiod utility first appeared in 4.4BSD.
Starting with FreeBSD 5.0, the utility no longer starts daemons, but only serves as a vfs loader and sysctl(3) wrapper.
|December 26, 2009||FreeBSD|