|KLDXREF(8)||FreeBSD System Manager's Manual||KLDXREF(8)|
NAMEkldxref — generate hints for the kernel loader
|kldxref||[ -Rdv][ -f hintsfile] path ...|
DESCRIPTIONThe kldxref utility is used to generate hint files which list modules, their version numbers, and the files that contain them. These hints are used by the kernel loader to determine where to find a particular KLD module.
A separate hint file is generated for each directory listed on the command line that contains modules. If no hint records are generated for a particular directory, no hint file is created, and the preexisting hint file (if there was one in that directory) is removed.
The following options are available:
- Recurse into subdirectories.
- Do not generate a hint file, but print module metadata on standard output.
- -f hintsfile
- Specify a different name for the hints files than linker.hints.
- Operate in verbose mode.
EXAMPLESTo build hint files for both standard and add-on modules:
kldxref /boot/kernel /boot/modules
To build hint files for all installed kernels:
kldxref -R /boot
HISTORYThe kldxref utility first appeared in FreeBSD 5.0.
AUTHORSThe kldxref utility was implemented by <bp@FreeBSD.org>. This manual page was written by <bp@FreeBSD.org> and <des@FreeBSD.org>.
|October 9, 2001||FreeBSD|