|ISCSID(8)||FreeBSD System Manager's Manual||ISCSID(8)|
NAMEiscsid — iSCSI initiator daemon
|iscsid||[ -P pidfile][ -d][ -l loglevel][ -m maxproc][ -t seconds]|
DESCRIPTIONThe iscsid daemon is responsible for performing the Login Phase of iSCSI connections, as well as performing SendTargets discovery.
Upon startup, the iscsid daemon opens the iSCSI initiator device file and waits for kernel requests. iscsid does not use any configuration files. All needed information is supplied by the kernel.
When the iscsid daemon is not running, already established iSCSI connections continue to work. However, establishing new connections, or recovering existing ones in case of connection error, is not possible.
The following options are available:
- -P pidfile
- Specify alternative location of a file where main process PID will be stored. The default location is /var/run/iscsid.pid.
- Debug mode. The server sends verbose debug output to standard error, and does not put itself in the background. The server will also not fork and will exit after processing one connection. This option is only intended for debugging the initiator.
- -l loglevel
- Specifies debug level. The default is 0.
- -m maxproc
- Specifies limit for concurrently running child processes handling connections. The default is 30. Setting it to 0 disables the limit.
- -t seconds
- Specifies timeout for login session, after which the connection will be forcibly terminated. The default is 60. Setting it to 0 disables the timeout.
- The iSCSI initiator device file.
- The default location of the iscsid PID file.
EXIT STATUSThe iscsid utility exits 0 on success, and >0 if an error occurs.
HISTORYThe iscsid command appeared in FreeBSD 10.0.
AUTHORSThe iscsid utility was developed by <trasz@FreeBSD.org> under sponsorship from the FreeBSD Foundation.
|September 12, 2014||FreeBSD|