|IPNAT(8)||FreeBSD System Manager's Manual||IPNAT(8)|
NAMEipnat - user interface to the NAT subsystem
SYNOPSISipnat [ -dhlnrsvCF ] [ -M core ] [ -N system ] -f < filename>
DESCRIPTIONipnat opens the filename given (treating "-" as stdin) and parses the file for a set of rules which are to be added or removed from the IP NAT.
Each rule processed by ipnat is added to the kernels internal lists if there are no parsing problems. Rules are added to the end of the internal lists, matching the order in which they appear when given to ipnat.
Note that if ipf(8) is not enabled when NAT is configured, it will be enabled automatically, as the same kernel facilities are used for NAT functionality. In addition, packet forwarding must be enabled.
- delete all entries in the current NAT rule listing (NAT rules)
- Enable printing of some extra debugging information.
- delete all active entries in the current NAT translation table (currently active NAT mappings)
- Print number of hits for each MAP/Redirect filter.
- Show the list of current NAT table entry mappings.
- This flag (no-change) prevents ipf from actually making any ioctl calls or doing anything which would alter the currently running kernel.
- This flag is used with the -r flag to cause any active NAT sessions that were created by the rules being removed and that are currently active to also be removed.
- Remove matching NAT rules rather than add them to the internal lists.
- Retrieve and display NAT statistics.
- Turn verbose mode on. Displays information relating to rule processing and active rules/table entries.