|DAEMON(8)||FreeBSD System Manager's Manual||DAEMON(8)|
NAMEdaemon — run detached from the controlling terminal
|daemon||[ -cfr][ -p child_pidfile][ -P supervisor_pidfile][ -u user] command arguments ...|
DESCRIPTIONThe daemon utility detaches itself from the controlling terminal and executes the program specified by its arguments. Privileges may be lowered to the specified user.
The options are as follows:
- Change the current working directory to the root (“ /”).
- Redirect standard input, standard output and standard error to /dev/null.
- -p child_pidfile
- Write the ID of the created process into the child_pidfile using the pidfile(3) functionality. The program is executed in a spawned child process while the daemon waits until it terminates to keep the child_pidfile locked and removes it after the process exits. The child_pidfile owner is the user who runs the daemon regardless of whether the -u option is used or not.
- -P supervisor_pidfile
- Write the ID of the daemon process into the supervisor_pidfile using the pidfile(3) functionality. The program is executed in a spawned child process while the daemon waits until it terminates to keep the supervisor_pidfile locked and removes it after the process exits. The supervisor_pidfile owner is the user who runs the daemon regardless of whether the -u option is used or not.
- Supervise and restart the program if it has been terminated.
- -u user
- Login name of the user to execute the program under. Requires adequate superuser privileges.
If the -p, -P or -r option is specified the program is executed in a spawned child process. The daemon waits until it terminates to keep the pid file(s) locked and removes them after the process exits or restarts the program. In this case if the monitoring daemon receives software termination signal (SIGTERM) it forwards it to the spawned process. Normally it will cause the child to exit, remove the pidfile(s) and then terminate.
The -P option is useful combined with the -r option as supervisor_pidfile contains the ID of the supervisor not the child. This is especially important if you use -r in an rc script as the -p option will give you the child's ID to signal when you attempt to stop the service, causing daemon to restart the child.
EXIT STATUSThe daemon utility exits 1 if an error is returned by the daemon(3) library routine, 2 if child_pidfile or supervisor_pidfile is requested, but cannot be opened, 3 if process is already running (pidfile exists and is locked), otherwise 0.
DIAGNOSTICSIf the command cannot be executed, an error message is displayed on standard error unless the -f flag is specified.
HISTORYThe daemon utility first appeared in FreeBSD 4.7.
|September 13, 2013||FreeBSD|