|SERVICES(5)||FreeBSD File Formats Manual||SERVICES(5)|
NAMEservices — service name data base
DESCRIPTIONThe services file contains information regarding the known services available in the Internet. For each service a single line should be present with the following information:
official service name port number protocol name aliases
Items are separated by any number of blanks and/or tab characters. The port number and protocol name are considered a single item; a ``/'' is used to separate the port and protocol (e.g. ``512/tcp''). A ``#'' indicates the beginning of a comment; subsequent characters up to the end of the line are not interpreted by the routines which search the file.
Service names may contain any printable character other than a field delimiter, newline, or comment character.
If “db” is specified as source in the nsswitch.conf(5), /var/db/services.db is searched. The database in /var/db/services.db needs to be updated with services_mkdb(8) after changes to the services file have been applied.
NIS INTERACTIONAccess to the NIS services.byname map can be enabled by adding a single ``+'' on a line by itself in the /etc/services file. This causes the contents of the NIS services map to be inserted at the location where the ``+'' appears.
- The services file resides in /etc.
HISTORYThe services file format appeared in 4.2BSD.
BUGSA name server should be used instead of a static file.
|April 4, 2010||FreeBSD|