EN JA
ISCSI.CONF(5)
ISCSI.CONF(5) FreeBSD File Formats Manual ISCSI.CONF(5)

NAME

iscsi.confiSCSI initiator configuration file

DESCRIPTION

The file iscsi.conf, is used by the iscsictl(8) and iscontrol(8) utilities. It contains declarations and parameter/key-options. The syntax is very simple,
variable = value;
and they can be grouped via a block declaration:

 # this is a comment 
 target_1 { # nickname 
    variable = value; 
    ... 
 } # this must be on a line by itself.

The following are specified in the iSCSI RFC 3720, for a full description see sections 11/12 of the RFC.

AuthMethod
currently only supported authentication method is CHAP, with digest either MD5 or SHA. Default is none.
HeaderDigest
a digest is calculated on the header of all iSCSI PDUs, and checked. Only CRC32C is implemented. Default is none.
DataDigest
same as for HeaderDigest, but on the data part of the iSCSI PDU. (not yet tested)
TargetName
is the name by which the target is known, not to be confused with target address, either obtained via the target administrator, or from a discovery session.
InitiatorName
if not specified, defaults to iqn.2005-01.il.ac.huji.cs: <hostname>.
TargetAddress
is of the form domainname[:port][,portal-group-tag] to quote the RFC:
The domainname can be specified as either a DNS host name, a dotted-decimal IPv4 address, or a bracketed IPv6 address as specified in [RFC2732].
Note: portal-group-tag is unused at the moment. not implemented yet.
MaxRecvDataSegmentLength
the maximum data segment length in bytes it can receive in an iSCSI PDU, default is 8192.
MaxOutstandingR2T
is used to calculate/negotiate the tag opening, can be overridden by the tag option.
SessionType
either Discovery or Normal, default is Normal, see the -d flag of iscontrol.
 

The following are not specified in the RFC 3720

port
The iSCSI port used by the iSCSI protocol, defaults to 3260.
tags
Sets the tag opening to the value specified.
maxluns
overrides the compiled value of luns, see iscsi_initiator(4). This value can only be reduced.
sockbufsize
sets the receiver and transmitter socket buffer size to size, in kilobytes. The default is 128.
 

If AuthMethod is set to CHAP, then the following must also be set:

chapSecret
this shared-secret. Can be either an ASCII string (e.g. hello world), a hex string (e.g 0xababcd0987654321...), or base64 string (eg 0b...)
chapIName
the chap-name, defaults to hostname.
chapDigest
can be MD5 or SHA1.
tgtChapName/tgtChapSecret
name and secret used for mutual CHAP; by default, mutual CHAP is not used.

FILES

/etc/iscsi.conf

EXAMPLES

# 
# Globals 
# 
port = 3260 
# 
myiscsi { # nickname 
   targetaddress = iscsi1 
   targetname  = iqn.1900.com.com:sn.123456 
} 
chaptest { 
   targetaddress= 10.0.0.1; 
   targetname = iqn.1900.com.com:sn.123456 
   initiatorname= iqn.2005-01.il.ac.huji.cs:nobody 
   authmethod = CHAP; chapDigest = SHA1; 
   chapsecret = 0x3713c3336d9a224c2791c873d3d2b174 
   tags  = 256 
}

STANDARDS

ISCSI RFC 3720

BUGS

Some options have not been implemented, either they were found to be unnecessary, or not understood, this can change in the future.
 
The tags opening value is difficult to calculate, use wisely.
December 17, 2013 FreeBSD