|DEVICE.HINTS(5)||FreeBSD File Formats Manual||DEVICE.HINTS(5)|
NAMEdevice.hints — device resource hints
DESCRIPTIONThe device.hints file is read in by the boot loader(8) when the system is about to start, and its contents are passed to the kernel. It contains various variables to control the boot behavior of the kernel. These variables are typically “device hints”.
The file contains one variable per line. Lines starting with the ‘
#’ character are comments and are ignored by the boot loader.
After the file is read by the boot loader, you may examine the variables with the show command, and may add a new variable, modify an existing one, or delete a variable with the set and unset commands of the boot loader (see loader(8)).
After the system has started, you can dump these variables with the kenv(1) command.
DEVICE HINTSDevice hint variables are used by device drivers to set up the device. They are most often used by ISA device drivers to specify where the driver will probe for the relevant devices, and what resources it will attempt to use.
A device hint line looks like:
hint.driver. unit. keyword
where driver is the name of a device driver, unit is the unit number, and keyword is the keyword of the hint. The keyword may be:
- specifies a bus to which the device is attached.
- specifies the start address of I/O ports to be used by the device.
- specifies the number of ports used by the device.
- is the interrupt line number to be used.
- is the DMA channel number.
- specifies the physical memory address used by the device.
- specifies the physical memory size used by the device.
- sets various flag bits for the device.
- can be set to “1” to disable the device.
A device driver may require one or more hint lines with these keywords, and may accept other keywords not listed here, through resource_int_value(9). Consult individual device drivers' manual pages for available keywords and their possible values.
- Device resource hints file.
- /sys/ ARCH /conf/GENERIC.hints
- Sample resource hints for the GENERIC kernel.
- /sys/ ARCH /conf/NOTES
- Notes on the kernel configuration file and device resource hints.
EXAMPLESThe following example sets up resources for the sio(4) driver on the ISA bus:
hint.sio.0.at="isa" hint.sio.0.port="0x3F8" hint.sio.0.flags="0x10" hint.sio.0.irq="4"
The following example disables the ACPI driver:
HISTORYThe device.hints file first appeared in FreeBSD 5.0.
|September 11, 2009||FreeBSD|