|WSP(4)||FreeBSD Kernel Interfaces Manual||WSP(4)|
NAMEwsp — Wellspring touchpad driver
SYNOPSISTo compile this driver into the kernel, place the following lines into your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe wsp driver provides support for the Apple Internal Trackpad device found in many Apple laptops.
The driver simulates a three-button mouse using multi-finger tap detection. A single-finger press generates a left button click. A two-finger tap maps to the right button; whereas a three-finger tap gets treated as a middle button click.
wsp supports dynamic reconfiguration using sysctl(8) through nodes under hw.usb.wsp. Pointer sensitivity can be controlled using the sysctl tunable hw.usb.wsp.scale_factor.
FILESwsp creates a blocking pseudo-device file, /dev/wsp0, which presents the mouse as a sysmouse or mousesystems type device--see moused(8) for an explanation of these mouse types.
AUTHORSThe wsp driver was written by <firstname.lastname@example.org>
|February 7, 2014||FreeBSD|