|UMASS(4)||FreeBSD Kernel Interfaces Manual||UMASS(4)|
NAMEumass — USB Mass Storage Devices driver
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe umass driver provides support for Mass Storage devices that attach to the USB port.
To use the umass driver, usb(4) and one of uhci(4) or ohci(4) must be configured in the kernel. Additionally, since umass uses the SCSI subsystem and sometimes acts as a SCSI device, it requires da(4) and scbus(4) to be included in the kernel.
HARDWAREThe umass driver supports USB Mass Storage devices, including:
- ADTEC Stick Drive AD-UST32M, 64M, 128M, 256M
- Denno FireWire/USB2 Removable 2.5-inch HDD Case MIFU-25CB20
- FujiFilm Zip USB Drive ZDR100 USB A
- GREEN HOUSE USB Flash Memory "PicoDrive" GH-UFD32M, 64M, 128M
- Huawei Mobile (SD slot)
- IBM 32MB USB Memory Key (P/N 22P5296)
- IBM 256MB USB Drive (MSYSTEM DiskOnKey2)
- IBM ThinkPad USB Portable CD-ROM Drive (P/N 33L5151)
- I-O DATA USB CD/CD-R/CD-RW/DVD-R/DVD-RW/DVD-RAM/DVD-ROM Drive DVR-iUH2 (CDROM, DVD-RAM only)
- I-O DATA USB x6 CD-RW Drive CDRW-i64/USB (CDROM only)
- I-O DATA USB/IEEE1394 Portable HD Drive HDP-i30P/CI, HDP-i40P/CI
- Iomega USB Zip 100/250 drive
- Iomega Zip750 USB2.0 drive
- Keian USB1.1/2.0 3.5-inch HDD Case KU350A
- Kurouto Shikou USB 2.5-inch HDD Case GAWAP2.5PS-USB2.0
- LaCie P3 HardDrive USB 200GB
- Logitec LDR-H443U2 DVD-RAM/-R/+R/-RW/+RW drive
- Logitec Mobile USB Memory LMC-256UD
- Logitec USB1.1/2.0 HDD Unit SHD-E60U2
- Logitec USB Double-Speed Floppy Drive LFD-31U2
- Logitec USB/IEEE1394 DVD-RAM/R/RW Unit LDR-N21FU2 (CDROM only)
- MELCO USB Flash Disk "ClipDrive", RUF-C32M, -C64M, -C128M, -C256M, -C512M
- MELCO USB Flash Disk "PetitDrive", RUF-32M, -64M, -128M, -256Mm
- MELCO USB2.0 Flash Disk "PetitDrive2", RUF-256M/U2, -512M/U2
- MELCO USB2.0 MO Drive MO-CH640U2
- Matshita CF-VFDU03 floppy drive
- Merlin SM300 MP3/WMA Player (256Mb)
- Microtech International, Inc. USB-SCSI-HD 50 USB to SCSI cable
- Motorola E398 Mobile Phone (TransFlash memory card)
- NOVAC USB2.0 2.5/3.5-inch HDD Case NV-HD351U
- PNY Attache Flash Drive
- Panasonic ("Matshita FDD CF-VFDU03")
- Panasonic KXL-CB20AN Portable DVD-ROM/CD-R/RW
- Panasonic KXL-CB35AN (DVD-ROM & CD-R/RW)
- Panasonic USB2.0 Portable CD-RW Drive KXL-RW40AN (CDROM only)
- Panasonic floppy drive
- Qware BeatZkey! Pro
- RATOC Systems USB2.0 Removable HDD Case U2-MDK1, U2-MDK1B
- SanDisk SDDR-31 (Compact Flash)
- SanDisk SDDR-75 (only Compact Flash port works)
- Sitecom CN-300 MultiFlash (MMC/SD, SmartMedia, CF, MemoryStick)
- Sony Portable CD-R/RW Drive CRX10U (CDROM only)
- TEAC Portable USB CD-ROM Unit CD-110PU/210PU
- Time DPA20B MP3 Player (1Gb)
- Trek Thumbdrive 8MB
- VAIO floppy drive (includes Y-E Data Flashbuster-U)
- Y-E Data floppy drive (720/1.44/2.88Mb)
Among the supported digital cameras are:
- Asahi Optical (PENTAX) Optio 230 & 330
device umass device scbus device da device pass
Add the umass driver to the kernel.
camcontrol rescan 0
Rescan a Zip drive that was added after boot. The command above assumes that the Zip drive is on the first SCSI bus in the system.
camcontrol rescan 0:0:0 camcontrol rescan 0:0:1 camcontrol rescan 0:0:2 camcontrol rescan 0:0:3
Rescan all slots on a multi-slot flash reader, where the slots map to separate LUNs on a single SCSI ID. Typically only the first slot will be enabled at boot time. Again, this assumes that the flash reader is the first SCSI bus in the system.
bsdlabel -w da0 zip100 newfs da0c mount -t ufs /dev/da0c /mnt
Create a new FAT type file system. Care should be taken not to run newfs(8) on devices that already contain data, as this will result in the information being lost.
Many consumer devices such as digital cameras automatically create MS-DOS based file systems when storing information such as images and videos. These file systems can be accessed by specifying the file system type as msdosfs when using mount(8).
AUTHORSThe umass driver was written by <firstname.lastname@example.org> and <n_hibma@FreeBSD.org>.
This manual page was written by<n_hibma@FreeBSD.org>.
|October 22, 2009||FreeBSD|