|UCHCOM(4)||FreeBSD Kernel Interfaces Manual||UCHCOM(4)|
NAMEuchcom — WinChipHead CH341/CH340 serial adapter driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe uchcom driver provides support for the WinChipHead CH341/CH340 USB-to-RS-232 Bridge chip.
HARDWAREThe uchcom driver supports the following adapters:
- HL USB-RS232
HISTORYThe uchcom driver first appeared in NetBSD. The first FreeBSD release to include it was FreeBSD 8.0.
BUGSActually, this chip seems unable to drive other than 8 data bits and 1 stop bit line.
|November 20, 2011||FreeBSD|