|TERASIC_MTL(4)||FreeBSD Kernel Interfaces Manual||TERASIC_MTL(4)|
NAMEterasic_mtl — driver for the Terasic/Cambridge Multi-Touch LCD device
DESCRIPTIONThe terasic_mtl device driver provides support for the Terasic Multi-Touch LCD combined as controlled by a University of Cambridge's IP Core. Three device nodes are instantiated, representing various services supported by the device:
- Memory-mapped register interface, including touch screen input.
- Memory-mapped pixel-oriented frame buffer.
- Memory-mapped text-oriented frame buffer.
terasic_mtl devices are also attached to the syscons(4) framework, which implements a VT-compatible terminal connected to the tty(4) framework.
ttyvX device nodes may be added to ttys(5) in order to launch login(1) sessions at boot.
HISTORYThe terasic_mtl device driver first appeared in FreeBSD 10.0.
AUTHORSThe terasic_mtl device driver and this manual page were developed by SRI International and the University of Cambridge Computer Laboratory under DARPA/AFRL contract (FA8750-10-C-0237) (“CTSRD”), as part of the DARPA CRASH research programme. This device driver was written by .
BUGSThe syscons(4) attachment does not support the hardware cursor feature.
A more structured interface to control registers using the ioctl(2) system call, would sometimes be preferable to memory mapping. For touch screen input, it would be highly desirable to offer a streaming interface whose events can be managed using poll(2) and related system calls, with the kernel performing polling rather than the userspace application.
terasic_mtl supports only a
nexus bus attachment, which is appropriate for system-on-chip busses such as Altera's Avalon bus. If the IP core is configured off of another bus type, then additional bus attachments will be required.
|August 18, 2012||FreeBSD|