|TDFX(4)||FreeBSD Kernel Interfaces Manual||TDFX(4)|
NAMEtdfx — Voodoo Graphics and VoodooII Memory Access GLIDE device driver
DESCRIPTIONThis driver creates an entry in /dev that allows programs (mostly GLIDE-based software) to access the device memory of the Voodoo Graphics and VoodooII 3D accelerators created by 3Dfx, Inc. This provides an interface for applications based on the GLIDE API or that simply use the API provided by the linux /dev/3dfx device to use the video device.
Supports all cards based on the following chipsets:
- 3Dfx Voodoo Graphics
- 3Dfx Voodoo II
Specifically, the following cards should work:
- Diamond Multimedia Monster 3D
- Diamond Multimedia Monster 3D II
Note that this driver does not currently have support for the Voodoo Banshee, Voodoo3, Voodoo5, or Voodoo6 based cards. It also does not currently support the Voodoo Rush. It also does not yet handle the SLI feature of the Voodoo II boards. You can only use each of them separately.
By including tdfx_linux, you can enable the linux ioctl code for this driver, where the only supported applications currently reside.
- Symlinked to default 3dfx board
Character Device programming interface
- Mirrors of above interfaces
- (Some apps use /dev/voodoo)
HISTORYThe tdfx driver appeared in FreeBSD 5.0, and was originally developed for Linux kernel 2.0.x, later written for 2.2.x and 2.4.x.
AUTHORSThe driver was developed by <email@example.com> after the linux version of this driver by , , , <firstname.lastname@example.org> and <email@example.com> to be directly compatible with it and support the many GLIDE based games available for Linux and UNIX.
|February 19, 2001||FreeBSD|