|SND_UAUDIO(4)||FreeBSD Kernel Interfaces Manual||SND_UAUDIO(4)|
NAMEsnd_uaudio — USB audio and MIDI device driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe snd_uaudio driver provides support for USB audio class devices and USB MIDI class devices.
A USB audio device consists of a number of components: input terminals (e.g. USB digital input), output terminals (e.g. speakers), and a number of units in between (e.g. volume control).
Refer to the ‘
USB Audio Class Specification’ for more information.
SEE ALSOsound(4), usb(4)
USB Audio Class Specifications, http://www.usb.org/developers/devclass_docs/.
HISTORYThe snd_uaudio driver first appeared in FreeBSD 4.7.
AUTHORSThis manual page was adopted from NetBSD 1.6 and modified for FreeBSD by <hmp@FreeBSD.org>.
BUGSThe PCM framework in FreeBSD, as of this writing, does not handle device un-registrations in a properly abstracted manner, i.e., a detach request is refused by the PCM framework if the device is in use. It is necessary to allow the device un-registration to complete successfully, otherwise the PCM layer will panic.
|February 24, 2011||FreeBSD|