|OCE(4)||FreeBSD Kernel Interfaces Manual||OCE(4)|
NAMEoce — Device driver for Emulex OneConnect 10Gb network adapters
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONEmulex OneConnect adapters come in various skews and with different combinations of NIC, FCoE and iSCSI functions. The oce driver claims the NIC functions in all these adapters.
The oce driver supports VLAN Hardware offload, TCP checksum offload, TCP segmentation offload (TSO), Large receive offload (LRO), Bonding, Jumbo frames (from 1500 - 9000), Multiple TX queues, Receive-Side Scaling (RSS) and MSI-X interrupts.
HARDWAREThe oce driver supports the following network adapters:
- Emulex BladeEngine 2
- Emulex BladeEngine 3
- Emulex Lancer
UPDATING FIRMWAREAdapter firmware updates are persistent.
Firmware can be updated by following the steps below:
- Copy the below code to a Makefile:
KMOD=elxflash FIRMWS=imagename.ufi:elxflash .include <bsd.kmod.mk>
- Replace imagename in above with UFI file name
- Copy Makefile and UFI file to a directory
- Execute make & copy generated elxflash.ko to /lib/modules
- sysctl dev.oce.<if_id>.fw_upgrade=elxflash
- Reboot the machine
In case of issues with supplied UFI, flashing fails with one of the following errors.
- “Invalid BE3 firmware image”
- “Invalid Cookie. Firmware image corrupted ?”
- “cmd to write to flash rom failed.”
SUPPORTFor general information and support, go to the Emulex website at: http://www.Emulex.com/ or E-Mail at firstname.lastname@example.org.
AUTHORSThe oce driver was written by .
|February 19, 2012||FreeBSD|