|NCV(4)||FreeBSD Kernel Interfaces Manual||NCV(4)|
NAMEncv — NCR 53C500 based SCSI host adapter driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe ncv driver provides access to the SCSI bus connected to an NCR 53C500 based PC-Card SCSI host adapter or an Adaptec AHA-2920 on the PCI bus.
HARDWAREThe following devices are currently supported by the ncv driver:
- I-O DATA PCSC-DV
- KME KXLC002 (TAXAN ICD-400PN, etc.), KXLC004, and UJDCD450
- Macnica Miracle SCSI-II mPS110
- Media Intelligent MSC-110, MSC-200
- NEC PC-9801N-J03R
- New Media Corporation BASICS SCSI
- Qlogic Fast SCSI
- RATOC REX-9530, REX-5572 (SCSI only)
DIAGNOSTICSThe following error messages are sometimes returned:
- SCSI BUS RESET failed
- Usually returned when a failure occurs during the bus reset.
- CMD_NOP failed
- No operation or the operation has failed.
- A failure occurred during the DMA read/write operations.
The ncv driver should return [ ENODEV] when any of the previously noted failures occur.
HISTORYThe ncv device driver has been developed for NetBSD/pc98 and ported to FreeBSD. The ncv driver first appeared in FreeBSD 2.2 with PAO and merged in FreeBSD 4.2.
AUTHORSThe ncv driver was written by . This manual page was written by <trhodes@FreeBSD.org> and <non@FreeBSD.org>.
|August 10, 2004||FreeBSD|