|NANDSIM(4)||FreeBSD Kernel Interfaces Manual||NANDSIM(4)|
NAMEnandsim — NAND Flash simulator driver
DESCRIPTIONThe nandsim is part of the FreeBSD NAND framework nand(4) and can be characterized with the following highlights:
- plugs into the nand(4) framework APIs as if it were a hardware controller (hanging on the nexus bus) with real NAND chips connected to it
- physically part of the kernel code (either statically linked into the kernel image or built as a module)
- controlled with a user space program nandsim(8)
From the user perspective, the nandsim allows for imitating ONFI-compliant NAND Flash devices as if they were attached to the system via a virtual controller.
Some nandsim features rely on the ability to log contents to a file, which is achieved through the alq(9) facility.
STANDARDSOpen NAND Flash Interface Working Group ( ONFI).
HISTORYThe nandsim support first appeared in FreeBSD 10.0.
AUTHORThe nandsim kernel driver was developed by . This manual page was written by .
|March 8, 2012||FreeBSD|