|MACHFB(4)||FreeBSD Kernel Interfaces Manual (SPARC64)||MACHFB(4)|
NAMEmachfb — accelerated color frame buffer
DESCRIPTIONThe ATI Mach64 family of chips are color frame buffers with graphics acceleration. The machfb driver interfaces those frame buffers with the syscons(4) console driver.
ATI Mach64 chips are very common as low-end graphics chips in PCI based UltraSPARC systems. They are found on-board in Sun Blade 100, Sun Blade 150, Sun Ultra 5 and Sun Ultra 10 as well as on Sun OEM mainboards like the Sun AXe. They are also used on add-on cards like the Sun PGX and Sun PGX64.
The machfb driver requires the chip which it is supposed to drive to be also supported by the Open Firmware, either by a built-in FCode driver package of the on-board firmware or by additional FCode on the add-on card. As a matter of course UltraSPARC systems with an on-board ATI Mach64 chip also have a built-in FCode driver package for this chip. There are also mainboards like the Sun AX1105 and Sun AXi boards however, which have built-in FCode for certain ATI Mach64 chips although they are not equipped with an on-board one. Mainboards with built-in FCode for certain ATI Mach64 chips can be used with any add-on card which is based on one of those chips, including cards which are equipped with x86 firmware and intended for use in PCs. Otherwise an add-on card which comes with its own FCode like the Sun PGX or Sun PGX64 has to be used.
HARDWAREThe machfb driver provides support for the following chips:
- ATI 3D Rage II+
- ATI 3D Rage IIC
- ATI 3D Rage I/II
- ATI 3D Rage LT
- ATI 3D Rage LT Pro
- ATI 3D Rage Pro
- ATI 3D Rage Pro Turbo
- ATI Mach64 CT
- ATI Mach64 VT
- ATI Mach64 VT4
- ATI Mach64 VTB
- ATI Rage L Mobility
- ATI Rage Mobility
- ATI Rage Mobility M1
- ATI Rage Mobility M3
- ATI Rage XC
- ATI Rage XL
The following add-on cards are known to work with the machfb driver at this time:
- ATI 3D Charger PCI
- Sun PGX 8-Bit Color Frame Buffer (part no. 370-2256)
- Sun PGX64 8/24-Bit Color Frame Buffer (part no. 370-4362)
HISTORYThe machfb driver first appeared in NetBSD 2.0. The first FreeBSD version to include it was FreeBSD 6.0.
AUTHORSThe machfb driver was written by <marius@FreeBSD.org> based on the NetBSD driver written by .
CAVEATSFont loading and mode switching are not implemented.
|September 2, 2006||FreeBSD|